mmen mmen
Home Forums Driver installation Problem installing Wifi booster Not compatible with Vista
 

Subject: Problem installing Wifi booster Not compatible with Vista


 
To Answer
Problem installing Wifi booster Not compatible with Vista
(Posted by: danjie, Sat, 22 Nov, 2008 09:38:04)
I purchased a dlink product to boost my wifi connection, unfortunately i forgot to check the system requirement of the product. when i tried to installit it was as to for xp update hotfix #### al though i have a vista os. please help me if i can still use the product. it was dlink DW645
 
mmen_l mmen_r
Term of use :: Privacy Policy
© 2005-2015 Copyright DriverStock.com All right reserved